Engineers deployed a fix at 20:05 UTC on May 28 and are now seeing successful backup operations across affected services. Backup and restore functionality for Veeam Data Cloud for Microsoft Entra ID has been restored, and we are no longer observing customer impact. Please contact support if you continue to experience any issues.
Resolved
Engineers deployed a fix at 20:05 UTC on May 28 and are now seeing successful backup operations across affected services. Backup and restore functionality for Veeam Data Cloud for Microsoft Entra ID has been restored, and we are no longer observing customer impact. Please contact support if you continue to experience any issues.
Identified
Starting at 19:30 UTC on May 28, some Veeam Data Cloud for Microsoft Entra ID customers may experience service disruptions affecting backup and restore operations. Affected customers will see backup failures and may be unable to perform restores until the issue is resolved. Our engineering teams have identified the issue and are working to implement a fix, which is expected within the next few hours. We will provide updates as they become available.