Veeam Data Cloud

Email notification delays
Resolved·Partial outage

Resolving

Tue, Sep 30, 2025, 06:22 PM
(1 month ago)
·
Affected components
Updates

Resolved

Resolving

Tue, Sep 30, 2025, 06:22 PM

Investigating

Mailjet has resolved the issue: https://status.mailjet.com/incidents/fntld4k6fdd3

Tue, Sep 30, 2025, 06:22 PM

Investigating

We are currently experiencing delays in sending emails outbound from VDC. Our 3rd party email service is currently experiencing issues and we will provide additional updates as we receive them from the vendor. 

Tue, Sep 30, 2025, 01:02 PM(5 hours earlier)