Veeam Data Cloud

M365 - "Mailbox is not fully configured" Error During Exchange Backup
Monitoring·Degraded performance

The root cause has been identified with the solution ready to be rolled out. This solution will be distributed within the maintenance cycles preliminary scheduled this week (you may track here)

Mon, Oct 27, 2025, 08:41 PM
(2 days ago)
·
Affected components
Updates

Monitoring

The root cause has been identified with the solution ready to be rolled out. This solution will be distributed within the maintenance cycles preliminary scheduled this week (you may track here)

Mon, Oct 27, 2025, 08:41 PM

Identified

The root cause has been identified and we are finalizing a solution. We appreciate your patience as we work to resolve this issue as soon as possible.

Fri, Oct 24, 2025, 12:48 PM(3 days earlier)

Investigating

We have identified an issue that is causing Exchange backup failures for some customers, with an error message of "Mailbox is not fully configured." Veeam's team is working with Microsoft to remediate the issue. An update will be provided when it's resolved.

Wed, Oct 22, 2025, 05:05 PM(1 day earlier)