Microsoft has now officially confirmed their Azure issues have been resolved.
Over the past hour and a half, we’ve been actively monitoring system performance and are seeing consistently positive results across all Veeam Data Cloud products.
Key workflows have been validated and are functioning as expected including those accessed through legacy portals.
Resolved
Microsoft has now officially confirmed their Azure issues have been resolved.
Over the past hour and a half, we’ve been actively monitoring system performance and are seeing consistently positive results across all Veeam Data Cloud products.
Key workflows have been validated and are functioning as expected including those accessed through legacy portals.
Monitoring
We are now seeing response times across our services recovering to acceptable levels.
We will continue monitoring and provide another update in about an hour.
Identified
Microsoft is progressively implementing fixes and we are now experiencing intermittent failures & timeouts.
We are continuing to monitor the situation closely and will provide additional updates when the system has stabilized.
Identified
Although users are still unable to access the Veeam Data Cloud application, we have confirmed that backups continue to operate as expected for our Veeam Data Cloud Products.
We are continuing to assess our options to mitigate the remaining impacts to our user interface while Microsoft continues to work on full restoration of service in Azure.
Investigating
We are currently experiencing issues with Azure Cloud. Microsoft has confirmed an outage on their end and our engineering team is currently investigating further.