Service Degradation: PST Export Delays
Resolved·Partial outage

Our engineers have monitored system health overnight and confirmed that platform stability has returned to normal. The previous failures and delays encountered when exporting data to PST have been fully resolved.

Tue, Feb 10, 2026, 03:43 PM
(1 week ago)
·
Affected components
Updates

Resolved

Our engineers have monitored system health overnight and confirmed that platform stability has returned to normal. The previous failures and delays encountered when exporting data to PST have been fully resolved.

Tue, Feb 10, 2026, 03:43 PM

Monitoring

Our engineers have applied a fix as of 12:00 UTC to address the recent service interruptions. We have confirmed that systems are currently performing as expected and will continue to monitor service health overnight to ensure ongoing stability. The next update will be provided around 16:00 UTC after further observation.

Tue, Feb 10, 2026, 02:14 AM(13 hours earlier)

Monitoring

Targeted changes were applied to mitigate the current PST export failures. The system and associated changes will continue to be monitored and we will provide additional updates as the situation evolves.

Fri, Feb 6, 2026, 09:49 PM(3 days earlier)

Investigating

We are currently investigating an issue where some customers may experience failures or delays when exporting data to PST. At this time, restore functionality remains fully operational and is not impacted. Our engineering teams are actively debugging the issue, which appears to be related to a recent Microsoft update affecting PST background processing. We are working to mitigate the impact and will provide further updates as more information becomes available.

Fri, Feb 6, 2026, 04:20 PM(5 hours earlier)