Microsoft Azure outage in West US impacting some backups
Resolved·Degraded performance

Between 08:00 UTC on February 06 and 02:15 UTC on February 07, Veeam Data Cloud experienced issues due to a widespread outage with Microsoft Azure that impacted customers in the US West region.  Microsoft has confirmed that all Azure services are now healthy.  Veeam Data Cloud engineers have also confirmed service restoration.  

 

For more information on the Microsoft Azure outage, please refer to Microsoft's status page: https://azure.status.microsoft/en-us/status

Sun, Feb 8, 2026, 04:45 AM
(1 week ago)
·
Affected components
Updates

Resolved

Between 08:00 UTC on February 06 and 02:15 UTC on February 07, Veeam Data Cloud experienced issues due to a widespread outage with Microsoft Azure that impacted customers in the US West region.  Microsoft has confirmed that all Azure services are now healthy.  Veeam Data Cloud engineers have also confirmed service restoration.  

 

For more information on the Microsoft Azure outage, please refer to Microsoft's status page: https://azure.status.microsoft/en-us/status

Sun, Feb 8, 2026, 04:45 AM

Investigating

Starting at 08:00 UTC, Veeam Data Cloud began experiencing issues due to a widespread outage in Microsoft Azure impacting customers in the US West region. Customers in the West US region may see some failed backups. More information regarding this outage can be found on Microsoft’s status page here: https://azure.status.microsoft/en-us/status

Further updates will be provided when more information is obtained from Microsoft.

Sat, Feb 7, 2026, 07:05 PM(9 hours earlier)