As of 00:45 UTC on February 09, full functionality has been restored for all backups previously impacted by service interruptions. The issue originated from a widespread Microsoft outage that affected our underlying infrastructure, but all systems are now performing as expected. Please reach out to support if you experience any further issues.
Resolved
As of 00:45 UTC on February 09, full functionality has been restored for all backups previously impacted by service interruptions. The issue originated from a widespread Microsoft outage that affected our underlying infrastructure, but all systems are now performing as expected. Please reach out to support if you experience any further issues.
Investigating
Some backups may be experiencing degraded performance. We are actively investigating the issue.