Intermittent Backup Failures: Veeam Data Cloud for M365
Monitoring·Degraded performance

Our engineers implemented a fix as of 21:09 UTC. Previously impacted backup service functionality has been restored for all M365 customers. We will continue to monitor service health overnight to ensure stability and confirm that no further issues arise.

Thu, Feb 12, 2026, 09:19 PM
(18 hours ago)
·
Affected components
Updates

Monitoring

Our engineers implemented a fix as of 21:09 UTC. Previously impacted backup service functionality has been restored for all M365 customers. We will continue to monitor service health overnight to ensure stability and confirm that no further issues arise.

Thu, Feb 12, 2026, 09:19 PM

Identified

Starting around 06:00 UTC on February 09, Veeam Data Cloud began experiencing service performance issues for backups on M365.  Our engineering teams are engaged and actively working to restore functionality. We appreciate your patience and will provide updates as soon as more information is available.

Thu, Feb 12, 2026, 06:38 PM(2 hours earlier)