Between 20:03 UTC on February 14th and 17:23 UTC on February 15th, Veeam Data Cloud experienced a service disruption impacting Entra ID customers. During this period, some customers may have experienced failed backup jobs. Our engineering team has mitigated the issue and confirmed through overnight monitoring that service stability has returned to normal levels. Please reach out to support if you experience any further issues.
Resolved
Between 20:03 UTC on February 14th and 17:23 UTC on February 15th, Veeam Data Cloud experienced a service disruption impacting Entra ID customers. During this period, some customers may have experienced failed backup jobs. Our engineering team has mitigated the issue and confirmed through overnight monitoring that service stability has returned to normal levels. Please reach out to support if you experience any further issues.
Monitoring
Starting on Sunday, February 15, Veeam Data Cloud experienced a service disruption impacting Entra ID customers across all regions. During this window, affected users may have encountered intermittent or total backup failures within their environments. Our engineering team identified the root cause and successfully implemented a mitigation to restore functionality as of 17:30 UTC. We are currently monitoring the service closely to ensure stability and prevent any recurrence.
Investigating
Starting on Sunday, February 15, Veeam Data Cloud experienced a service disruption impacting Entra ID customers across all regions. During this window, affected users may have encountered intermittent or total backup failures within their environments. Our engineering team identified the root cause and successfully implemented a mitigation to restore functionality as of 17:30 UTC. We are currently monitoring the service closely to ensure stability and prevent any recurrence.