Between 17:00 UTC on March 17th and 08:00 UTC on March 18th, Veeam Data Cloud experienced an issue where M365 backups failed for some customers in the APJ region. Our engineers worked closely with Microsoft to identify and resolve the underlying infrastructure issue, and we can now confirm that backup functionality has been fully restored. All systems are operating normally. If you experience any further issues, please reach out to our support team for assistance.
Resolved
Between 17:00 UTC on March 17th and 08:00 UTC on March 18th, Veeam Data Cloud experienced an issue where M365 backups failed for some customers in the APJ region. Our engineers worked closely with Microsoft to identify and resolve the underlying infrastructure issue, and we can now confirm that backup functionality has been fully restored. All systems are operating normally. If you experience any further issues, please reach out to our support team for assistance.
Investigating
Starting at 17:00 UTC on March 17th, Veeam Data Cloud began experiencing an issue with M365 backups failing for some customers in the APJ region. Our engineers have opened a technical support ticket with Microsoft and are actively working alongside their team to resolve the underlying cause as quickly as possible. Further information will be provided as soon as more details are obtained from Microsoft.