Between 16:00 UTC on March 25 and 17:30 UTC on March 26, Veeam Data Cloud experienced an issue with VDC Azure tenant management. During this time, customers may have experienced issues with loading tenant data after selecting a tenant to manage in OneUI (blank page), which may have required multiple refreshes to recover. Veeam engineers have mitigated the issue and confirmed that services are fully functional. Please reach out to support if you experience any further issues.
Resolved
Between 16:00 UTC on March 25 and 17:30 UTC on March 26, Veeam Data Cloud experienced an issue with VDC Azure tenant management. During this time, customers may have experienced issues with loading tenant data after selecting a tenant to manage in OneUI (blank page), which may have required multiple refreshes to recover. Veeam engineers have mitigated the issue and confirmed that services are fully functional. Please reach out to support if you experience any further issues.
Investigating
Starting around 16:00 UTC on March 25, Veeam Data Cloud began experiencing an issue with VDC Azure tenant management for all Azure customers. During this time, customers may experience issues with loading tenant data after selecting a tenant to manage (blank page), which may require multiple refreshes to recover. Veeam engineers are actively working to resolve this issue.