Complete
Scheduled update is completed now
In progress
Maintenance in progress
Complete
All services are now operational in the impacted region
In progress
The ongoing issues have been mitigated and the region is operational
In progress
Maintenance has started
Scheduled
Veeam Data Cloud for Entra ID is experiencing some disruption in the East US region. The team is actively investigating the root cause and working on a fix. Tenants in this region might be impacted.