Resolved
Microsoft has mitigated the Azure issue affecting the West US region. We have confirmed that backup and restore services are now functioning as expected for customers.
If you experience any further issues, please contact Support.
Investigating
Due to Azure networking issues in the West US region, some customer may experience intermittent backup and restore failures or delays. Azure has implemented mitigations and is monitoring recovery; we are continuing to assess impact and will provide updates as more information becomes available.