Our engineering team has observed significant improvements to system health since Microsoft performed the rollback. We have not observed any further widespread impact related to this issue. If you experience any further issues, please reach out to support.
Resolved
Our engineering team has observed significant improvements to system health since Microsoft performed the rollback. We have not observed any further widespread impact related to this issue. If you experience any further issues, please reach out to support.
Monitoring
Microsoft has rolled back a change that was contributing to system stability issues affecting Microsoft 365 organization data updates and item selection when creating or editing granular backup policies. Since the rollback, we have observed improvements in system behavior. Our engineering team will continue to monitor the system closely for any further issues and will provide additional updates as needed.
Investigating
We are investigating an issue affecting multiple Microsoft 365 tenants where SharePoint sites and other items may not appear or update as expected when customers create or edit granular backup policies. Our engineering team is working with Microsoft, who has reverted a change that led to this degradation. We are monitoring the system to ensure these issues subside and will provide updates as more information is available.