Resolved
The fix has been deployed and we have confirmed that M365 Self-Service Restore users can access the portal again. This issue is resolved.
Monitoring
Workaround identified: Self-Service users may directly go to https://cloud.veeam.com/m365 to perform self-service restores.
Identified
Updating the incident to show that this is affecting all regions, not only Asia Pacific
Identified
We've identified a race condition regarding CDN resources specifically affecting M365 Self-Service Restore portal logins in the Asia-Pacific region. No admin users are affected nor any other functionality.
Investigating
M365 Self-Service